心向远方 爱在未来
路由器基本配置
  • 首页 > >
  • 作者:PC小可
  • 2019年12月17日 14:32 星期二
  • 浏览:81
  • 字号:
  • 评论:0

  • 2.1 路由器简介和IOS简介

    2.1.1 路由器简介

    路由器能起到隔离广播域的作用,还能在不同网络间转发数据包。路由器实际上是一台

    特殊用途的计算机,和常见的 PC 机一样,路由器有 CPU、内存、BOOT ROM。路由器没有键

    盘、硬盘、显示器;然而比起计算机,路由器多了NVRAMFLASH以及各种各样的接口。路

    由器各个部件的作用如下:

    (1)  CPU:中央处理单元,和计算机一样,它是路由器的控制和运算部件。

    (2)  RAM/DRAM:内存,用于存储临时的运算结果,如:路由表、ARP 表、快速交换缓存、

    缓冲数据包、数据队列、当前配置。众所周知,RAM 中的数据在路由器断电后是会丢

    失的。

    (3)  FLASH:可擦除、可编程的ROM,用于存放路由器的IOSFLASH的可擦除特性允许我

    们更新、升级IOS而不用更换路由器内部的芯片。路由器断电后,FLASH的内容不会

    丢失。FLASH容量较大时,就可以存放多个IOS版本。

    (4)  NVRAM:非易失性RAM,用于存放路由器的配置文件,路由器断电后,NVRAM中的内容

    仍然保持。

    (5)  ROM:只读存储器,存储了路由器的开机诊断程序、引导程序和特殊版本的 IOS 软件

    (用于诊断等有限用途),ROM中软件升级时需要更换芯片。

    (6)  接口(Interface):用于网络连接,路由器就是通过这些接口和不同的网络进行连接

    的。

    2.1.2 IOS简介

    路由器也有自己的操作系统,通常称为IOSInternetwork Operating System)。和计

    算机上的Windows一样,IOS是路由器的灵魂,所有配置是通过IOS完成的。CiscoIOS

    是命令行界面(称为CLICommand Line Interface),CLI有两种基本工作模式:

    (1)  用户模式(User mode):通常用来查看路由器的状态。在此状态下,无法对路由器进

    行配置,可以查看的路由器信息也是有限的。

    (2)  特权模式(Privilegemode):可以更改路由器的配置,当然也可以查看路由器的所有

    信息。

    2-1  常用的编辑命令

    编辑键

    命令功能

    移动光标到命令行开头

    移动光标到命令行末尾

    重用前一条命令

    Crtl+A

    Crtl+E

    Crtl+P】(或【】)

    Crtl+N】(或【】)

    Esc+F

    重用下一条命令

    光标前移一个词

    Esc+B

    Crtl+F

    Crtl+B

    光标后移一个词

    光标前移一个字母

    光标后移一个字母

    2-1 “show”命令显示路由器的各种信息

    2-2  配置文件的流动

    虽然是命令行,CLI提供简单、丰富的编辑功能,如表2-1,熟悉它们是熟练配置路由

    器的基础。在CLI下可以使用“show”命令查看存放在路由中不同部件中的信息,如图2-1

    CLI下,我们可以在路由器的各种模式间进行切换来对路由器进行配置。

    我们对路由器进行配置后,可以把配置保存在NVRAM中,路由器开机时会自动读取。为

    了安全,可以通过TFTP服务器把配置文件备份在计算机上。路由器的配置文件可以在不同

    的部件间流动,流动如图2-2所示。

    路由器的IOS是如此重要,因此我们也需要通过TFTP服务器把IOS备份到计算机上。

    由于各种各样的原因,我们可能会不小心破坏了IOS,造成路由器无法开机,可以通过TFTP

    把之前备份出的IOS进行恢复。如果不慎忘记了路由器的密码,也可以进行恢复。


     

    2-3  路由器启动过程示意图

    Cisco 路由器开机后,首先执行一个开机自检过程(Power On Self TestPOST),诊

    断验证CPU、内存及各个端口是否正常,紧接路由器进入软件初始化过程。如图2-3,其步

    骤如下:

    (1) 执行 ROM 中的引导程序加载(Bootstrap Loader),它和计算机中的 BIOS  很类似,

    Bootstrap会把IOS装到RAM中;

    (2) IOS可以存放在许多地方(FLASHTFTP服务器上或ROM中),路由器寻找IOS映像的顺

    序,取决于配置寄存器的启动域以及其他的设置。配置寄存器(configuration

    register)是一个16位(2进制)的寄存器,低4位就是启动域,不同的值代表从不

    同的位置查找IOS,如表2-2。详细的IOS查找过程如图2-4所示。

    2-2  配置寄存器中启动于的值

    配置寄存器的值(16进制)

    描述

    0

    1

    使用ROM模式

    自动从ROM中启动

    2-F

    FLASHTFTP服务器启动

    2-4  路由器查找IOS的详细流程


     

    (3) 加载IOSRAM中:如果IOS是压缩过的,就先解压。

    (4) NVRAM中查找配置文件,并把配置文件加载到RAM中运行。

    (5) 如果在NVRAM中没有找到配置文件,就进入setup配置模式(也称为配置对话模式)。

    2.1.3 CDP协议介绍

    CDPCisco Discovery Protocol)协议是Cisco专有的协议,是使Cisco网络设备能

    够发现相邻的、直连的其他Cisco设备的协议。CDP是数据链路层的协议,因此使用不同的

    网络层协议的Cisco设备也可以获得对方的信息。CDP协议默认是启动的。

    2.2 实验1:CLI的使用与IOS基本命令

    1. 实验目的

    通过本实验,读者可以掌握如下技能:

    1  熟悉路由器CLI的各种模式

    2  熟悉路由器CLI各种编辑命令

    3  掌握路由器的IOS基本命令

    4  查看路由器的有关信息

    2. 实验拓扑

    2-5 实验1拓扑图

    3. 实验步骤

    1  步骤1:用户模式和特权模式的切换

    Router>

    Router>enable

    Router#

    Router#disable

    Router>

    //“Router”是路由器的名字,而“>”代表是在用户模式。“enable”命令可以使路由器从

    用户模式进入到特权模式,“disable”命令则相反,在特权模式下的提示符为“#”

    2  步骤2“?”和【Tab】键的使用,以配置路由器时钟为例

    Router>enable

    Router#clok

    Translating "clok"...domain server (255.255.255.255)

    (255.255.255.255)


     

    Translating "clok"...domain server (255.255.255.255)

    % Unknown command or computer name, or unable to find computer address

    //以上表明输入了错误的命令

    Router#cl?

    clear  clock

    //路由器列出了当前模式下可以使用的以“cl”开头的所有命令

    Router#clock

    % Incomplete command.

    //路由器提示命令输入不完整,

    Router#clock ?

    set  Set the time and date

    //要注意的是“?”“clock”之间要有空格,否则得到将不同的结果,如果不加空格路由

    器以为你是想列出以“clock”字母开头的命令,而不是想列出“clock”命令的子命令或参

    数。

    Router#clock set ?

    hh:mm:ss  Current Time

    Router#clock set 11:36:00

    % Incomplete command.

    Router#clock set 11:36:00 ?

    <1-31>  Day of the month

    MONTH   Month of the year

    Router#clock set 11:36:00 12 ?

    MONTH  Month of the year

    //以上多次使用帮助命令,获得了“clock”命令的格式

    Router#clock set 11:36:00 12 08

    ^

    % Invalid input detected at '^' marker.

    //路由器提示输入了无效的参数,并用“^”指示错误的所在

    Router#clock set 11:36:00 12 august

    % Incomplete command.

    Router#clock set 11:36:00 12 august 2003

    Router#show clock

    11:36:03.149 UTC Tue Aug 12 2003

    //到此成功配置了路由器的时钟,通常如果命令成功,路由器不会有任何提示。在CLI下,

    可以直接使用“?”命令获得当前模式下的全部命令。如下:

    Router# ?

    Exec commands:

    access-enable

    access-profile

    Create a temporary Access-List entry

    Apply user-profile to interface

    access-template  Create a temporary Access-List entry

    ……………………………………………//为了节约篇幅,此处省略了部分输出

    erase

    exit

    Erase a filesystem

    Exit from the EXEC

     


     

    help

    Description of the interactive help system

    --More—

    //有多于一屏的内容时,按【回车】键显示下一行,按【空格】显示下一页,其他键则退出

    Router#disable

    Router>en

    Router#

    //CLI中,命令是可以缩写的,但前提是路由器要能够区分得出,如下:

    Router#dis

    % Ambiguous command:

    Router#dis?

    "dis"

    disable

    disconnect

    //使用“dis”不能退出特权模式的原因是路由器无法区分出“dis”代表“disable”还是

    “disconnect”。若再加多一个字母“a”就可以区分了。

    Router#disa

    Router>enTab

    Router>enable

    Router#confTab tTab

    Router#configure terminal

    Router(config)#

    //可以使用【Tab】键帮助我们自动完成命令

    3  步骤3IOS编辑命令与历史命令缓存大小

    Router#show history

    en

    conf t

    show history

    dis

    disable

    enable

    conf t

    show history

    //以上是显示历史命令

    Router#terminal editing

    //以上是打开编辑功能,实际上这是默认的。用上下左右光标键试试移动光标,也可以试试

    使用表2-1的编辑键移动光标

    Router#terminal history size 50

    //以上把缓存的历史命令数改为50,默认值为10

    Router#terminal no editing

    //以上关闭terminal的编辑功能,则表2-1的编辑键失效

    Router#terminal editing

    4  步骤4:基本IOS命令

    先连接到R1路由器上:

    Router>enable

    Router#configure terminal

     


     

    Enter configuration commands, one per line.  End with CNTL/Z.

    Router(config)#hostname R1

    //以上改变路由器的名称为“R1”,设置立即生效。

    R1(config)#enable password cisco

    //以上改变了enable的密码为“cisco”,这个密码是从用户模式进入到特权模式的密码。

    R1(config)#interface g0/0

    //以上进入到接口模式,这里是千兆以太网口(第0个插槽的第0个接口,编号从0开始)。

    R1(config-if)#ip address 10.1.1.1 255.255.255.0

    //以上给以太接口配置一个IP地址10.1.1.1,掩码为255.255.255.0  

    R1(config-if)#no shutdown

    //以上开启以太网口,因为默认时路由器的各个接口是关闭的。

    R1(config-if)#exit

    //退回到上一级模式

    R1(config)#interface s0/0/0

    //以上进入到接口模式,这里是串行接口

    R1(config-if)#ip address 10.12.12.1 255.255.255.0

    //以上给串行接口配置一个IP地址

    R1(config-if)#no shutdown

    //以上开启接口

    R1(config-if)#end(或【Ctrl+Z】)

    //以上结束配置直接回到特权模式下。

    R1#copy running-config startup-config

    Destination filename [startup-config]?

    Building configuration...

    [OK]

    //以上把内存中的配置保存到NVRAM中,路由器开机时会读取它。

    连接到R2路由器上,进行以下操作:

    Router>enable

    Router#configure terminal

    Enter configuration commands, one per line.  End with CNTL/Z.

    Router(config)#hostname R2

    R2(config)#enable password cisco

    R2(config)#interface g0/0

    R2(config-if)#ip address 10.2.2.2 255.255.255.0

    R2(config-if)#no shutdown

    R2(config-if)#exit

    R2(config)#interface s0/0/0

    R2(config-if)#ip address 10.12.12.2 255.255.255.0

    R2(config-if)#clock rate 128000

    //R2这一端是DCE,需要配置时钟

    R2(config-if)#no shutdown

    R2(config-if)#end

    R2#copy running-config startup-config

     


     

    Destination filename [startup-config]?

    Building configuration...

    [OK]

    R2#ping 10.12.12.1

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 10.1.14.126, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

    //R2 ping R1的串行接口,可以ping

    5  步骤5:各种“show”命令

    R2#show version

    Cisco IOS Software,  2800 Software (C2800NM-ADVENTERPRISEK9-M),  Version 12.4(11)T1, RELEASE

    SOFTWARE (fc5)

    Technical Support: http://www.cisco.com/techsupport

    Copyright (c) 1986-2007 by Cisco Systems, Inc.

    Compiled Thu 25-Jan-07 12:50 by prod_rel_team

    //以上是IOS的版本信息

    ROM: System Bootstrap, Version 12.4(1r) [hqluong 1r], RELEASE SOFTWARE (fc1)

    //以上是ROM的版本信息

    R2 uptime is 4 hours, 10 minutes  //注:路由器的开机时间

    System returned to ROM by power-on  //路由器是如何启动的,例如:开电或者热启动

    System image file is "flash:c2800nm-adventerprisek9-mz.124-11.T1.bin"

    //注:以上是当前正在使用的IOS文件名

    (此处省略)

    If you require further assistance please contact us by sending email to

    export@cisco.com.

    Cisco 2821 (revision 53.50) with 249856K/12288K bytes of memory.

    //注:以上是路由型号、RAM大小(249856K+12288K

    Processor board ID FHK1039F1FG  //主板系列号

    2 Gigabit Ethernet interfaces

    4 Low-speed serial(sync/async) interfaces

    1 Virtual Private Network (VPN) Module

    //注:以上是各种接口的数量

    DRAM configuration is 64 bits wide with parity enabled.

    239K bytes of non-volatile configuration memory.

    62720K bytes of ATA CompactFlash (Read/Write)

    //注:以上是NVRAMFLASH的大小情况

    Configuration register is 0x2142

    //以上是配置寄存器的值

     


     

    R2#show running-config

    Building configuration...

    Current configuration : 1238 bytes

    !

    version 12.4

    service timestamps debug datetime msec

    service timestamps log datetime msec

    no service password-encryption

    !

    hostname R2

    ……………………(此处省略)

    //以上显示路由正在使用的配置文件(存放在RAM中),通常配置文件为几百到几千字节

    R2#show startup-config

    Building configuration...

    Current configuration : 1238 bytes

    !

    version 12.4

    //以上显示路由NVRAM中的配置文件

    R2#show interface s0/0/0

    Serial0/0/0 is up, line protocol is up   //注:该接口的状态

    Hardware is GT96K Serial

    Internet address is 10.12.12.2/24  //注:该接口的IP地址

    MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec,

    reliability 255/255, txload 1/255, rxload 1/255

    //注:以上是该接口的MTU、带宽、延时、可靠性、负载大小

    Encapsulation HDLC, loopback not set  //注:串口的封装类型为HDLC

    Keepalive set (10 sec)

    ……………………(此处省略)

    R2#show flash

    CompactFlash directory:

    File  Length

    Name/status

    1   41205996  c2800nm-adventerprisek9-mz.124-11.T1.bin

    [41206060 bytes used, 23019216 available, 64225276 total]

    62720K bytes of ATA CompactFlash (Read/Write)

    //显示了flash中存放的IOS情况,flash的总大小,可用空间

    R2#show controllers s0/0/0

    Interface Serial0/0/0

    Hardware is GT96K

     


     

    DCE V.35, clock rate 128000

    idb at 0x4728A8C0, driver data structure at 0x4728CBEC

    wic_info 0x4728D218

    Physical Port 1, SCC Num 1

    //显示s0/0/0接口为v.35接口,且为DCE,已经配置了时钟

    R2#show ip arp

    Protocol  Address

    Age (min)  Hardware Addr   Type   Interface

    Internet  172.16.0.2

    Internet  172.16.0.100

    //以上显示路由中缓存的ARP

    -   0019.5566.6320  ARPA   GigabitEthernet0/0

    3   000c.7650.df17  ARPA   GigabitEthernet0/0

    2.3 实验2:配置文件的备份和IOS的备份

    1. 实验目的

    通过本实验,读者可以掌握如下技能:

    1  熟悉TFTP服务器的使用

    2  熟悉备份路由器的配置文件

    3  掌握备份路由器的IOS

    2. 实验拓扑

    2-6 实验2拓扑图

    3. 实验步骤

    1  步骤1TFTP SERVER软件的安装、准备

    2-7 TFTP Server主窗口

    Tftp服务器软件有各种各样,本书以SolarWinds  TFTP Server软件为例,该软件可以

    http://solarwinds.net上免费下载。下载后安装后,运行该软件,如图2-7。从【File


     

    Configure】菜单打开配置窗口,如图2-8。在“TFTP Root Directory”选项卡中,可

    以看到TFTP的主目录为c:\tftp-rootTFTP  Server接收到的文件将存放在该目录,也从

    该目录查找要发送的文件。如图 2-9,在“Security”选项卡中,配置该 TFTP 可以接收和

    发送文件。

    2-8 查看TFTP服务器的主目录

    2-9 配置TFTP  Server可以接收和发送文件

    2  步骤2:路由器和计算机间的IP可达

    首先确保S1交换机为出厂配置,如果不是的话,请执行以下命令:

    Switch>enable

    Switch#delete flash:vlan.dat

    Switch#erase startup-config

    其次在PC机上配置IP地址为172.16.0.100/16

    R2(config)#int g0/0

    R2(config-if)#no shutdown

    R2(config-if)#ip address 172.16.0.2 255.255.0.0

    R2(config-if)#exit

    //以上在路由器的以太网接口配置IP地址,并启用接口

    R2#ping 172.16.0.100


     

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 172.16.0.100, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

    //测试从R2PCTFTP服务器)的IP可达

    3  步骤3:备份配置文件到TFTP服务器

    R2#copy running-config tftp:

    //把内存中的配置文件备份到TFTP服务器上

    Address or name of remote host []? 172.16.0.100  //回答TFTP服务器的IP地址

    Destination filename [r2-confg]?   //回答文件名,默认时为路由器名-confg”

    !!

    1381 bytes copied in 0.452 secs (3055 bytes/sec)

    //备份成功,共1381字节,可以在c:\tftp-root目录下找到该文件,是一个纯文本的文件。

    可以用写字板打开,而用记事本打开则格式会出现问题

    4  步骤4:采用复制、粘贴备份配置文件

    使用TFTP服务器备份配置文件很是麻烦,我们也可以简单地在终端窗口中,执行“show

    running-config”命令显示当前的配置,在终端窗口中复制全部配置,粘贴到某文本文件

    中。

    【提示】如果是在Windows自带的超级终端窗口中复制、粘贴配置,会有“---more---”

    字样,要记得删除这些字符。

    5  步骤5:备份配置IOSTFTP服务器

    R2#show flash:

    CompactFlash directory:

    File  Length   Name/status

    1   41205996  c2800nm-adventerprisek9-mz.124-11.T1.bin

    [41206060 bytes used, 23019216 available, 64225276 total]

    62720K bytes of ATA CompactFlash (Read/Write)

    //先查看flash中的IOS大小,文件名等

    R2#copy flash:c2800nm-adventerprisek9-mz.124-11.T1.bin tftp:

    //IOS备份到TFTP服务器上

    Address or name of remote host []? 172.16.0.100   //回答TFTP服务器的IP地址

    Destination filename [c2800nm-adventerprisek9-mz.124-11.T1.bin]?

    //回答文件名。默认时和源文件名是一样的,不建议修改文件名,因为 IOS 文件名包含了

    IOS的版本、特征等信息

    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!(此处省略)

    //备份成功可以在c:\tftp-root目录下找到该文件。

    2.4 实验3:密码恢复和IOS的恢复

    1. 实验目的

    通过本实验,读者可以掌握如下技能:

    1  熟悉路由器的密码恢复步骤

     


     

    2  熟悉路由器的IOS恢复步骤

    2. 实验拓扑

    2-10 实验3拓扑图

    3. 实验步骤

    1  步骤1:在路由器上配置密码

    Router>enable

    Router#configure terminal

    Enter configuration commands, one per line.  End with CNTL/Z.

    Router(config)#hostname R2

    R2(config)#enable password 309nasfdndf12

    //故意配置一个自己也记不住的密码,以供密码恢复使用

    2  步骤2:路由器密码恢复

    关闭路由器电源并重新开机,当控制台出现启动过程,赶快按【Ctrl+Break】键中断路

    由器的启动过程,进入rommon模式,如下:

    System Bootstrap, Version 12.4(1r) [hqluong 1r], RELEASE SOFTWARE (fc1)

    Copyright (c) 2005 by cisco Systems, Inc.

    Initializing memory for ECC

    c2821 processor with 262144 Kbytes of main memory

    Main memory is configured to 64 bit mode with ECC enabled

    Readonly ROMMON initialized

    rommon 1>confreg 0x2142

    //改变配置寄存器的值为0x2142,这会使得路由器开机时不读取NVRAM中的配置文件 

    rommon 2 > i

    //重启路由器。路由器重启后会直接进入到setup配置模式,用【Ctrl+C】或者回答“n”

    退出setup模式。

    Router>enable

    Router#copy startup-config running-config

    Destination filename [running-config]?

    661 bytes copied in 0.625 secs

    //把配置文件从NVRAM中拷贝到RAM中,在此基础上修改密码。

    R2#configure terminal

    R2(config)#enable password cisco

    //以上把密码改为自己的密码,如果还配置别的密码则一起把它们修改了。

    R2(config)#config-register 0x2102

    //以上把寄存器的值恢复为正常值0x2102

    R2(config)#exit

    R2#copy running-config startup-config


     

    Destination filename [startup-config]?

    Building configuration...

    [OK]

    R2#reload

    //以上是保存配置,重启路由器,检查路由器是否正常

    【提示】在保存配置前,还需要把路由器的各个接口一一打开

    3  步骤3:故意删除flash中的IOS,我们要恢复IOS

    R2#show flash:

    CompactFlash directory:

    File  Length   Name/status

    1   41205996  c2800nm-adventerprisek9-mz.124-11.T1.bin

    [41206060 bytes used, 23019216 available, 64225276 total]

    62720K bytes of ATA CompactFlash (Read/Write)

    //显示flash中的IOS

    R2#delete flash:c2800nm-adventerprisek9-mz.124-11.T1.bin

    Delete filename [c2800nm-adventerprisek9-mz.124-11.T1.bin]?

    Delete flash:c2800nm-adventerprisek9-mz.124-11.T1.bin? [confirm]

    //以上是删除flashIOS,模拟FLASH中的IOS丢失或者IOS升级失败

    【提示】请慎重进行该步骤。如果工作中不慎误删IOS,请不要将路由器关机,可以直接使

    “copytftpflash”命令从TFTP服务器恢复IOS,这比起我们下面介绍的方法简单得多。

    除了从TFTP恢复IOS,还可以用Xmodem方式通过console口恢复IOS,然而由于console

    的速度很慢,很少有人采用。

    4  步骤4:恢复IOS

    请确认 IOS 已经放在 c:\ TFTP-Root 目录下。路由器丢失了 IOS 后,开机将自动进入

    rommon模式。

    rommon 2 > IP_ADDRESS=172.16.0.2

    rommon 3 > IP_SUBNET_MASK=255.255.0.0

    rommon 4 > DEFAULT_GATEWAY=172.16.0.100

    rommon 5 > TFTP_SERVER=172.16.0.100

    rommon 6 > TFTP_FILE=c2800nm-adventerprisek9-mz.124-11.T1.bin

    //要恢复 IOS,需要配置一些变量的值,主要是路由器的 IP 地址、掩码等。由于路由器和

    TFTP 服务器在同一网段,是不需要网关的,但是不能不配置该值,所以我们把

    DEFAULT_GATEWAY 胡乱地指向了TFTP服务器。请注意变量名的大小写。

    rommon 8 > tftpdnld

    //开始从tftp恢复IOS

    IP_ADDRESS: 172.16.0.2

    IP_SUBNET_MASK: 255.255.0.0

    DEFAULT_GATEWAY: 172.16.0.100

    TFTP_SERVER: 172.16.0.100

    TFTP_FILE: c2800nm-adventerprisek9-mz.124-11.T1.bin

    TFTP_VERBOSE: Progress

     


     

    TFTP_RETRY_COUNT: 18

    TFTP_TIMEOUT: 7200

    TFTP_CHECKSUM: Yes

    TFTP_MACADDR: 00:19:55:66:63:20

    GE_PORT: Gigabit Ethernet 0

    GE_SPEED_MODE: Auto

    Invoke this command for disaster recovery only.

    WARNING: all existing data in all partitions on flash will be lost!

    Do you wish to continue? y/n:  [n]:  y

    //回答“y”开始从tftp服务器上恢复IOS,根据IOS的大小,通常需要十几分钟

    Receiving

    c2800nm-adventerprisek9-mz.124-11.T1.bin

    from

    172.16.0.100 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    (此处省略)

    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    File reception completed.

    Validating checksum.

    Copying file c2800nm-adventerprisek9-mz.124-11.T1.bin to flash.

    Eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee

    //tftp服务器接收了IOS后,会进行校验。

    rommon 9 > i

    //重启路由器

    2.5 实验4:CDP

    1. 实验目的

    通过本实验,读者可以掌握如下技能:

    1  查找CDP邻居

    2  熟悉CDP的配置

    2. 实验拓扑

    2-11 实验4拓扑图

    3. 实验步骤

    1  步骤1:打开接口

    R1(config)#int g0/0

    R1(config-if)#no shutdown

    R1(config-if)#int s0/0/0

    R1(config-if)#no shutdown


     

    R2(config)#int g0/0

    R2(config-if)#no shutdown

    R2(config-if)#int s0/0/0

    R2(config-if)#no shutdown

    R2(config-if)#clock rate 128000

    //以上是打开路由器间互连的各个接口,而默认时交换机S1的所有接口就是打开的。

    2  步骤:查看CDP配置

    R1#show cdp

    Global CDP information: Global CDP information:

    Sending CDP packets every 60 seconds

    Sending a holdtime value of 180 seconds

    Sending CDPv2 advertisements is  enabled

    //默认时CDP是运行的,每60秒从接口发送cdp消息;发送出的CDP消息,邻居会为它保

    180

    R1#show cdp interface

    GigabitEthernet0/0 is up, line protocol is up

    Encapsulation ARPA

    Sending CDP packets every 60 seconds

    Holdtime is 180 seconds

    GigabitEthernet0/1 is administratively down, line protocol is down

    Encapsulation ARPA

    Sending CDP packets every 60 seconds

    Holdtime is 180 seconds

    Serial0/0/0 is down, line protocol is down

    Encapsulation HDLC

    Sending CDP packets every 60 seconds

    Holdtime is 180 seconds

    Serial0/0/1 is administratively down, line protocol is down

    Encapsulation HDLC

    Sending CDP packets every 60 seconds

    Holdtime is 180 seconds

    //以上显示在哪些接口运行CDP协议

    3  步骤3:查看CDP邻居

    R1#show cdp neighbors

    Device ID

    Local Intrfce

    Ser 0/0/0

    Gig 0/0

    Holdtme

    137

    Capability  Platform  Port ID

    R2

    S1

    R S I

    S I

    2821

    Ser 0/0/0

    172

    WS-C3560- Fas 0/1

    //以上显示R1路由器有两个邻居:R2S1“DeviceID”表示邻居的主机名;“LocalIntrfce”

    表明 R1 通过该接口和邻居连接,注意是 R1 上的接口;“Holdtme”指收到邻居发送的 CDP

    消息的时间,采用倒计时;“Capability”表明邻居是什么设备,第一、二行CapabilityCodes

    对各符号进行了说明;“Platform”指明了邻居的硬件型号;“PortID”指明了R1是连接对

    方的哪个接口上。

     


     

    R1#show cdp entry R2

    -------------------------

    Device ID: R2

    Entry address(es):

    Platform: Cisco 2821,  Capabilities: Router Switch IGMP

    Interface: Serial0/0/0,  Port ID (outgoing port): Serial0/0/0

    Holdtime : 158 sec

    Version :

    Cisco IOS Software,  2800 Software (C2800NM-ADVENTERPRISEK9-M),  Version 12.4(11)T1, RELEASE

    SOFTWARE (fc5)

    Technical Support: http://www.cisco.com/techsupport

    Copyright (c) 1986-2007 by Cisco Systems, Inc.

    Compiled Thu 25-Jan-07 12:50 by prod_rel_team

    advertisement version: 2

    VTP Management Domain: ''

    //以上是显示邻居R2的详细信息,甚至可以知道邻居的IOS版本

    R1#clear cdp table

    //清除CDP

    4  步骤4:关、启CDP;调整CDP参数

    R1(config)#int g0/0

    R1(config-if)#no cdp enable

    //以上是在g0/0接口上关闭cdp,其他接口还运行CDP

    R1(config-if)#exit

    R1(config)#no cdp run

    //以上是在整个路由器上关闭cdp

    R1(config)#cdp run

    //在整个路由器上打开cdp

    R1(config)#cdp timer 30

    //调整CDP消息发送时间为30

    R1(config)#cdp holdtime 120

    //调整CDP消息的holdtime120,对方收到该路由器发送的CDP消息后将保持120

    R1#show cdp

    Global CDP information:

    Sending CDP packets every 30 seconds

    Sending a holdtime value of 120 seconds

    Sending CDPv2 advertisements is  enabled

    2.6 本章小结

    本章介绍了路由器的硬件组成,介绍了CLI界面的几种模式、各种编辑命令。IOS有着

    大量的命令,本章主要介绍路由器的基本初始化命令。还介绍了路由器配置文件保存、备份,

    密码的恢复,IOS的备份和恢复。表2-3是本章出现的命令。

     


     

    2-3 本章命令汇总

    命令

    作用

    clock set

    设置路由器的时间

    show clock

    show history

    显示路由器的时间

    显示历史命令

    terminal no editing

    terminal editing

    关闭CLI的编辑功能

    打开CLI的编辑功能

    terminal history size 50

    copy running-config startup-config

    clock rate 128000

    修改历史命令缓冲区的大小

    把内存中的配置文件保存到NVRAM

    配置串口上的时钟(DCE)

    显示路由器的IOS版本等信息

    显示内存中的配置文件

    show version

    show running-config

    show startup-config

    显示NVRAM中的配置文件

    show interface s0/0/0

    show flash

    显示接口的信息

    显示flash的有关信息

    show controllers s0/0/0

    show ip arp

    显示s0/0/0的控制器信息

    显示路由器中的arp

    copy running-config tftp

    copy tftp running-config

    copy

    把内存中的配置文件拷贝到tftp服务器上

    tftp服务器上的配置文件拷贝到内存中

    flash中的IOS拷贝到tftp服务器上

    flash:c2800nm-adventerprisek9-mz.124-1

    1.T1.bin tftp

    confreg 0x2142

    rommon模式下修改配置寄存器值

    rommon模式下重启路由器

    NVRAM中的配置文件拷贝到内存中

    修改配置寄存器值

    i

    copy startup-config running-config

    config-register 0x2102

    reload

    重启路由器

    delete

    删除flash中的IOS

    flash:c2800nm-adventerprisek9-mz.124-1

    1.T1.bin

    copy tftp flash

    tftpdnld

    tftp服务器上拷贝IOSflash

    rommon模式下,从tftp服务器下载IOS

    显示CDP运行信息

    show cdp

    show cdp interface

    show cdp neighbors

    show cdp entry R2

    clear cdp table

    no cdp enable

    显示CDP在各接口的运行情况

    显示CDP邻居信息

    显示CDP邻居R2的详细信息

    清除CDP邻居表

    接口下关闭CDP

    no cdp run/ cdp run

    关闭/打开整个路由器的CDP

    cdp timer 30

    CDP30秒发送一次

    cdp holdtime 120

    让邻居为本设备发送的CDP消息保持120


      您阅读这篇文章共花了:  
     本文无需标签!
    二维码加载中...
    本文作者:PC小可      文章标题: 路由器基本配置
    本文地址:http://www.senmumu.cn/?post=7
    版权声明:若无注明,本文皆为“森木木博客”原创,转载请保留文章出处。